BulkMailer Professional Online Hilfe

Willkommen in der BulkMailer Hilfe

Aktuelle Version: BulkMailer 2012  (Download)

BulkMailer Screenshot

BulkMailer dient dem komfortablen Versenden von Serien-EMails aus einer Datenbank. (Bulk heißt übersetzt Masse~, also Massen-Mailer.)

Wahlweise können Sie dazu eine vordefinierte (interne) Datenbank verwenden oder auf eine bestehende Datenbank zugreifen. Über Microsoft-Data-Access-Components (MDAC) / OLE-DB / ODBC ist der Zugriff auf beinahe jede Datenquelle möglich.

Die Inhalte von Datenfeldern können in den Mailtext integriert werden; auf diese Weise lassen sich u.a. personalisierte Anreden generieren.

Verwenden Sie BulkMailer für Newsletter, Kundeninformationen etc.

Achtung: Das Versenden von EMails ohne vorige Zustimmung der Empfänger (sogenannte SPAM-Mails) ist verboten ! BulkMailer wurde nicht zu diesem Zweck entwickelt. Die Nutzung dieser Software für SPAM-Mails verstößt gegen die Lizenzbestimmungen.

Bevor Sie das Programm verwenden...

  1. Konfigurieren Sie das Programm
  2. Bestellen Sie kostenlos und unverbindlich eine DEMO-PIN.
  3. Die PIN wird Ihnen automatisch in wenigen Sekunden per EMail zugesendet.
  4. Testen Sie die Konfiguration durch das Versenden von Testmails

In 4 Schritten zum Mailing

  1. Importieren Sie Adressen in die interne Datenbank
  2. oder greifen Sie direkt auf eine bestehende Datenbank zu
  3. Verfassen Sie eine Mail
  4. Wählen Sie "Mailing generieren".
  5. Die Mails werden dabei in den Postausgang gelegt
  6. Wählen Sie "Mailing versenden"
 

Viel Spaß und Erfolg wünscht

Detlef Kroll - Kroll Software-Entwicklung

 

Optionen

Bevor Sie das Programm zum Mailversand nutzen können, müssen Sie unter Extras->Optionen einige Einstellungen vornehmen:

Options

Tragen Sie hier Ihren SMTP-Server ein. SMTP steht für Simple Mail Transfer Protocol. Wenn Sie unsicher sind, sehen Sie in Ihrem Mailprogramm nach, z.B. in Outlook Express unter Konten->EMail.

Erkundigen Sie sich bei Ihrem Systemadministrator oder Provider, welchen Mailserver Sie verwenden können. Oft heissen diese Server "mail.Ihr-Provider.de" oder "smtp.Ihr-Provider.de".

SMTP-Server werden normalerweise an Port 25 betrieben. Nur in seltenen Fällen geben Sie hier einen anderen Port an.

Der Standard SMTP-Port lautet 25.

Wählen Sie 60 (Sekunden) als Standard. Wählen Sie einen kleineren Wert, um bei Verbindungsfehlern schneller abzubrechen.

Tragen Sie hier Ihre gültige Absender-Email-Adresse ein. z.B. "ihr.name@ihr-provider.de". Verwenden Sie die EMail-Adresse, mit der Sie Serienmails versenden wollen. Für diese EMail-Adresse benötigen Sie eine gültigen /de/help-chapter/bulkmailer-pin/, welcher an diese Adresse gekoppelt ist. Eine Demo-PIN erhalten Sie kostenlos.

Tragen Sie hier Ihren vollständigen Namen oder Firmennamen ein.

Reply To: Dieses Feld wird vom Mailclient des Empfängers ausgewertet, wenn dieser auf "Antworten" klickt. Die Antwort-Mails gehen dann an diese abweichende Adresse.

Return-Path: Der Return-Path wird ausschließlich von Maschinen ausgewertet, während die Absenderadresse vom Mailclient ausgewertet wird. Durch einen abweichenden Return-Path können s.g. Bounce-Mails an eine abweichende Adresse geleitet werden.

Error-To: Dieser Email-Header ist der Vollständigkeit halber angeboten, wird jedoch nicht von allen Mailservern unterstützt.

Organization: Ihr Firmenname. Dieser Header wird nur von wenigen Mailclients dargestellt.

Die meisten SMTP-Server sind heute durch SMTP-Authentifizierung gegen unbefugte Nutzung geschützt. Ihre Zugangsdaten (Benutzername und Passwort) zu Ihrem Postfach erhalten Sie von Ihrem Systemadministrator oder Provider. (Die SMTP-Zugangsdaten sind meist identisch mit Ihrem POP3 LogIn.)

--> Siehe auch Probleme: Authentifizierung bei SMTP-Servern

Einige Provider erfordern noch die vorige Anmeldung am POP3 Postfach, bevor Sie Mails versenden können. Das wird heute aber nur noch selten eingesetzt. Tragen Sie in diesem Fall hier Ihre POP3 Zugangsdaten ein.

Einige Provider erlauben nur eine begrenzte Anzahl von Mails pro Sitzung. In einem solchen Fall kann BulkMailer automatisch nach einer bestimmten Anzahl Mails die Verbindung zum SMTP-Server beenden, eine einstellbare Zeit warten, um sich dann erneut anzumelden und mit dem Versand fortzufahren.

Wählen Sie eine geeignete Codepage, mit der Ihre Mails versendet werden sollen. Es geht dabei um die richtige Darstellung von Umlauten und Sonderzeichen. Wenn Sie ausschliesslich deutschsprachige oder englische Texte versenden, wählen Sie Westeuropäisch/USA, um eine bestmögliche Lesbarkeit zu erreichen.

Sobald Sie in anderen Sprachen (chinesisch, japanisch, etc.) schreiben oder Sonderzeichen (z.B. das EURO Symbol) verwenden wollen, empfehlen wir den UTF-8 Zeichensatz. Dieser Standard ist zeitgemäß und erlaubt das Schreiben in allen Sprachen durcheinander. Allerdings können veraltete Mailclients und leider auch noch einige Freemail-Provider UTF-8 Mails noch nicht richtig darstellen.

 

BulkMailer PIN

 

Tragen Sie unter Extras->Optionen Ihre gültige Absender-EMail-Adresse ein und die dazu passende PIN. Eine kostenlose DEMO-PIN zum Testen des Programms können Sie in wenigen Sekunden erhalten (s.u.).

PIN Validierung

Vor dem Mailversand prüft das Programm die Gültigkeit einer persönlichen Identifikations Nummer (PIN). Diese ist an eine oder mehrere bestimmte Absenderadresse(n) gebunden.

Durch diesen Mechanismus soll ein Missbrauch des Programms vermieden werden. Davon profitieren alle Anwender, die das Programm für seriöse Serienmails einsetzen wollen.

Kroll-Software versichert, daß bei der PIN-Überprüfung keine weiteren Daten übertragen werden. Ihre Email-Adresse wird nicht an Dritte weitergegeben.

PIN Validierung

Fordern Sie Ihre DEMO-PIN zur Evaluierung an

Geben Sie dazu Ihre gültige Absender-Email-Adresse unter Extras->Optionen ein.

Klicken Sie dann auf den Button "Demo-PIN anfordern". Die PIN wird Ihnen in wenigen Sekunden an die angegebene Absender-EMail zugesendet.

Kroll-Software versichert, daß bei der PIN-Anforderung keine weiteren Daten übertragen werden. Ihre EMail-Adresse wird nicht an Dritte weitergegeben.

Tragen Sie diese PIN dann in das PIN-Feld unter Extras->Optionen ein und klicken Sie auf den Button "Pin testen". Es sollte kurz die Meldung "DEMO-PIN" erscheinen.

Wenn Sie einen Fehler wie "Host not found" erhalten, prüfen Sie, ob eine Anti-Viren Software oder eine Personal Firewall den Zugriff blockiert.

Die DEMO-PIN bleibt 30 Tage gültig. Die Versendung von Attachments ist in der Evaluierungsphase nicht möglich.

Falls Sie Probleme oder Fragen zur PIN-Bestellung haben, können Sie sich gerne per Email oder telefonisch an Kroll-Software wenden.

Lizensierung der Vollversion

Wenn Sie das Programm länger als 30 Tage nutzen wollen, müssen Sie eine Lizenz erwerben. EU Firmen können Lizenzen gegen Rechnung bestellen.

Hier können Sie bestellen.

Testmails versenden

 

Nachdem Sie das Programm vollständig konfiguriert haben und eine Demo-PIN eingetragen haben, können Sie den Mailversand testen, indem Sie einige Testmails an sich selbst versenden.

  1. Wählen Sie den Menüpunkt "Mailing -> Testmails generieren".
  2. Bestätigen Sie die Frage "10 Testmails an .. generieren ?" mit Ja
  3. Das Programm wechselt zum Postausgang und zeigt 10 Testmails
  4. Vergewissern Sie sich, daß Ihr Computer online ist
  5. Wählen Sie den Menüpunkt "Mailing -> Mailing versenden"
  6. Es erscheint ein Dialog zu den Lizenzvereinbarungen
  7. Lesen Sie den Lizenztext
  8. Falls Sie den Vereinbarungen zustimmen, markieren Sie das entsprechende Feld und klicken Sie auf "EMails versenden."
  9. Ihre PIN wird überprüft und das Programm wechselt zum Mail-Versenden Dialog
  10. Klicken Sie auf "Start !"

Die Testmails werden nun an Ihre (die eingetragene Absender-Email-) Adresse versendet.

Falls ein Fehler wie "We do not relay" oder "authentication failed" erscheint, ist möglicherweise der Zugang zu Ihrem SMTP-Server nicht richtig konfiguriert, oder Sie besitzen nicht die Berechtigung, über diesen Server Mails zu versenden. Siehe auch Probleme: Authentifizierung bei SMTP-Servern

BulkMailer Adressdatenbank

 

Nutzen Sie die interne BulkMailer Adressdatenbank, um Ihre Empfängeradressen direkt in BulkMailer zu verwalten. Alternativ können Sie auch direkt auf eine bestehende Datenbank zugreifen, um daraus ein Mailing zu generieren.

Die interne Adressedatenbank erlaubt die Generierung einer persönlichen Anrede. Anredearten sind dabei bestimmten Gruppen zugeordnet. All dies ist frei konfigurierbar.

Adressen verwalten

Beim ersten Starten legt BulkMailer automatisch eine leere Adressdatenbank an (Adressen.bm3).

Wählen Sie den Menüpunkt Bearbeiten -> Neue Adresse (F6) oder klicken Sie auf das entsprechende Icon.

Es erscheint der Dialog zur Doublettensuche. Geben Sie hier die EMail-Adresse ein. Falls die Adresse bereits in der Datenbank besteht, wird die Fundstelle aufgelistet. Sie können dann diesen Datensatz anzeigen oder eine neue EMail-Adresse eingeben.

Falls der Datensatz noch nicht in der Datenbank besteht, erscheint die leere Eingabe-Maske. Das EMail-Feld ist bereits ausgefüllt. Folgende Felder sollten Sie hier mindestens erfassen, um automatische Anreden generieren zu können:

  • Vor- und Nachname bzw. Firmenname
  • Geschlecht
  • Gruppe

In der Statuszeile wird die automatische Anrede angezeigt. Diese ist von der gewählten Gruppe abhängig.

Klicken Sie auf OK, um den Datensatz zu speichern.

Doppelklicken Sie auf eine Adresse in der Tabellenansicht. Die Eingabemaske öffnet sich zum Ändern der Daten.

Markieren Sie eine oder mehrere Adresse(n) in der Tabellenansicht und drücken Sie die 'Entf.'-Taste oder klicken Sie auf das entspr. Icon.

Tabellen-Ansicht der Adressen

Im Hauptfenster klicken Sie auf die Registerkarte 'Adressen'.

Klicken Sie auf eine Spaltenüberschrift, um nach dieser Spalte zu sortieren.

Klicken Sie auf das Icon 'Gruppieren'. Ziehen Sie dann eine Spaltenüberschrift auf den Bereich 'Spalte zum Gruppieren hierher ziehen'. Es erscheinen nun Gruppen die jeweils auf und zugeklappt werden können. Vordefinierte Gruppierungen können Sie durch die Auswahl (Pfeil) neben dem Gruppier-Icon auswählen.

Um zur ungruppierten Ansicht zurückzukehren, klicken Sie erneut auf das Icon 'Gruppieren'.

Klicken Sie auf das Fernglas-Icon (Strg-F), um innerhalb der angezeigten Tabelle zu suchen. Klicken Sie auf das kleinere Fernglas (F3), um weiterzusuchen.

Die Suchfunktionen verwenden einen zeichenketten-Vergleich und sind daher relativ langsam. Um in größeren Datenbeständen nach Adressen zu suchen, sollten Sie die Auswahl-Funktionen verwenden.

Die Auswahlfunktionen basieren auf SQL-Abfragen und sind daher sehr schnell. Es stehen 2 verschiedene Dialoge zur Verfügung:

  • Schnelle Suche - F6 (häufig verwendete Felder, nur bei interner Datenbank)
  • Erweiterte Suche - F7 (beliebige Auswahl, auch in externen Datenbanken)

Die aktuelle Auswahl ist auch für die Mail-Generierung gültig. D.h., wenn Sie auf 'Mailing generieren' klicken und 'aktuelle Auswahl' wählen, wird das Mailing aus der aktuellen Auswahl zusammengestellt.

Sie können Adressen direkt in der Tabelle bearbeiten. Markieren Sie dazu das entsprechende Icon. Hierbei ist allerdings Vorsicht geboten; Änderungen können nicht rückgängig gemacht werden.

Mehrere Adress-Datenbanken verwalten

Wählen Sie die Menüpunkte unter 'Datei', um

  • Eine neue Adressdatenbank anzulegen
  • Eine bestehende Adressdatenbank zu öffnen

Die aktuelle Adressdatenbank wird in der Titelleiste des Programms angezeigt. Jede Adressdatenbank besitzt ihre eigenen selbstdefinierten Gruppen und Anreden.

 

Andere Datenquelle

 

Folgende Gründe sprechen für die Verwendung einer externen Datenbank:

  1. Ihr Unternehmen pflegt bereits eine Adressdatenbank, Kundendatenbank o.ä. Hier wäre es zu umständlich, die aktuelle Version dieser Datenbank jedesmal zu importieren.
  2. Die Struktur der internen Datenbank ist für Ihre Zwecke nicht ausreichend; Sie benötigen weitere Felder, z.B. für mehrsprachige Anreden, Textbausteine, etc.
 
  • Ihr bestehendes DBMS (Datenbank Management System) verfügt über einen ODBC-Treiber oder besser: über einen OLE-DB Treiber. Treiber für dBase, FoxPro, Access, MS-SQL-Server, ... sind bereits durch MS-Jet 4.0 vorhanden.
  • Ihre Datenbank enthält mindestens eine Spalte mit EMail-Adressen.

Empfohlene DBMS: MS-Access, MS-SQL-Server

So funktioniert's

  1. Wählen Sie im Hauptmenü "Datei->Andere Datenquelle öffnen->..."
  2. Stellen Sie eine Verbindung zu Ihrer Datenquelle her. Je nach Datenquelle erscheinen unterschiedliche Dialoge.
  3. Bei erfolgreicher Verbindung zur Datenbank erscheint nun der Dialog zur Auswahl der Tabelle oder Abfrage.
  4. BulkMailer muß nun wissen, welche Spalte die EMail-Adressen enthält. Machen Sie im folgenden Dialog zumindest diese Angabe.

Wenn alles funktioniert hat, wird die Datenbank in Tabellenform unter "Adressen" angezeigt.

Damit Sie diese aufwendige Prozedur nicht wiederholen müssen, können Sie nun diese Datenbankverbindung abspeichern. Wählen Sie dazu im Hauptmenü "Datei -> Externe Datenverbindung speichern...". Beim nächsten Mal öffnen Sie diese Datei dann über "Datei -> Externe Datenbank öffnen -> Gespeicherte Datenverbindung".

Ab hier funktioniert nun alles wie bei der internen Datenbank, mit folgenden Einschränkungen:

  • Datensätze können in BulkMailer nicht bearbeitet werden. Nutzen Sie dazu Ihr DBMS.
  • Die automatische Anrede, Verwaltung von Gruppen, etc. müßten Sie in Ihrer externen Datenbank realisieren. Vorteilhaft wäre beispielsweise ein Anredefeld, welches die komplette Anrede enthält ("Sehr geehrter Herr Müller"). Dieses Datenbankfeld können Sie dann als Anrede in Ihre Mail integrieren.
 
Zugriff auf ACT!10

Siehe Dokumentation als PDF

 

Neue Mail

 

Am linken Fensterrand unter "Mailings:" erscheinen alle angelegten Mailtexte. Wählen Sie im Hauptmenü "EMail -> Neue EMail", um eine neue Mail anzulegen.

Weitere Optionen zur Verwaltung der Mails erscheinen, wenn Sie mit der rechten Maustaste auf einen Eintrag in der Liste "Mailing" klicken:

Mailing Optionen bei rechter Maustaste
  • Mailing umbenennen
  • Neues Mailing anlegen
  • Mailing löschen

Verfassen des Mail-Textes

Wählen Sie eine bestimmte Mail aus, bevor Sie den Text bearbeiten können.

Wechseln Sie zur Registerkarte "Nachricht" und geben Sie dort Ihren Text ein. Vergessen Sie nicht, einen Betreff anzugeben.

Weiter:

 

HTML Mails

Erstellen von ansprechenden HTML-Mails

BulkMailer besitzt einen Html-Editor mit Funktionen, wie sie für ein Email-Programm typisch sind.

Wenn Ihnen dies nicht genügt und Sie komplexes Html erstellen wollen

  • Nutzen Sie dazu einen Html-Editor Ihrer Wahl
  • Speichern Sie die Html-Datei auf Ihre Festplatte
  • Laden Sie diese in den BulkMailer über den Menüpunkt "Email->Webseite aus Datei laden"

Falls Sie keine genügenden Kenntnisse zum Erstellen von Html besitzen, wäre das evtl. auch eine gute Aufgabe für Ihren Webdesigner.

 

BulkMailer 2012 bietet volle Unterstützung von HTML-Mails

Sobald Ihre Email Textformatierungen oder eingebettete Bilder enthalten soll, handelt es sich um s.g. HTML-Mails. Fast alle modernen EMail-Clients sind heute in der Lage, solche HTML-Mails anzuzeigen.

Für ältere Email-Clients fügt BulkMailer automatisch einen ASCII-Part zur Email hinzu, sodass diese den enthaltenen Text anzeigen können. (Das Verfahren nennt sich Multipart/Alternative)

  • Erstellen Sie HTML-Mails mit dem integrierten Editor.
  • Grafiken können wahlweise zusammen mit der EMail versendet werden, oder als Verweis auf eine Grafik, die auf einem Webserver liegt, eingebunden werden.

So erstellen und versenden Sie HTML-Mails

  1. Wählen Sie im Hauptmenü EMail->Neue EMail (HTML)
  2. Oder konvertieren Sie eine bestehende Mail durch den Menüpunkt EMail->Format HTML
  3. Im Nachrichteneditor sehen Sie nun eine zusätzliche Toolbar mit Funktionen zur Text- und Seitenformatierung sowie zum Einfügen von Grafiken und Verweisen.
Einfügen von Bildern
  1. Klicken Sie in der Toolbar auf das Icon Bild einfügen
  2. Es erscheint der Dialog Bild
    • Klicken Sie auf Bildherkunft->Durchsuchen und wählen Sie eine Grafikdatei aus.
      Ein so ausgewähltes Bild wird zusammen mit Ihrer EMail versendet.
    • Oder geben Sie die URL zu einem Bild auf einem Webserver ein.
      Diese Grafik wird dann nicht mit der EMail versendet.
      Stattdessen wird das Bild beim Lesen der Nachricht im EMail-Programm des Empfängers von der angegebenen URL heruntergeladen und angezeigt.

Bitte beachten Sie:

Eingebundene Bilder müssen zum Zeitpunkt des Versendens an ihrem Speicherort vorhanden sein.

Einfügen von Verweisen (Links)
  1. Markieren Sie einen Textabschnitt oder ein Objekt (z.B. Bild)
  2. Klicken Sie in der Toolbar auf das Icon Link erstellen
  3. Geben Sie im folgenden Dialog die URL ein.
MS-Frontpage als HTML-Editor

Um komplexe HTML-Mails zu erstellen, können Sie auch MS-Frontpage oder andere HTML-Editoren verwenden. Speichern Sie die Datei als HTML-Datei ab und wählen Sie anschließend "EMail->Webseite aus Datei laden", um diese Datei zu öffnen. BulkMailer passt beim Öffnen relative Pfade zu Bilddateien automatisch an.

MS-Word als HTML-Editor

Speichern Sie das Word-Dokument als gefiltertes HTML ab. Format 'Webseite (gefiltert)'

Wählen Sie anschließend in BulkMailer den Menüpunkt "EMail->Webseite aus Datei laden", um diese Datei zu öffnen.

MS-Publisher as HTML-Editor

Siehe MS-Publisher zum Gestalten der HTML-Mail

Allgemeine Hinweise zum Versenden von HTML-Mails

Verwendete Schriften

Bei HTML-Mails gilt dasselbe wie bei Webseiten:
Sie sollten nur Schriftarten verwenden, die auch auf dem Rechner des Empfängers vorhanden sind. Das sind typischerweise Arial, Times New Roman, Courier New, (Verdana, Tahoma, Comic Sans, Impact) etc. Nicht vorhandene Schriften werden beim Empfänger evtl. durch andere Schriften ersetzt dargestellt.

Bilder als Verweis versenden

Es ist für Newsletter durchaus typisch, dass Bilder nicht zusammen mit der Mail, sondern nur als Verweis auf eine Grafik auf einem Webserver eingebunden werden. Letzteres hat folgende Vorteile:

  • Die Mail wird wesentlich kleiner, dadurch schneller versendet und beim Empfänger schneller geöffnet.
  • Bei verlinkten Grafiken können Sie durch Auswertung der Logfiles Ihres Webservers die Abrufrate ihrer Mail auswerten.

Felder einfügen

 

Am linken Fensterrand unter "Felder" werden alle verfügbaren Datenbankfelder aufgelistet. Drag und drop (anfassen und ziehen) Sie ein solches Feld, um es in den Mail-Text einzufügen.

Beim Generieren der Mails werden später diese Platzhalter durch die Datenbankinhalte ersetzt.

Eine Besonderheit stellt das Feld [Anrede] dar: es fügt die personalisierte Anrede ein (diese Funktion ist nur in Verbindung mit einer BulkMailer-Adressdatenbank verfügbar).

Diese Anrede ist frei konfigurierbar, siehe Anreden

Dateianhänge

 

BulkMailer versendet auch Dateianhänge (Attachments). Klicken Sie auf die Büroklammer, um eine Datei an die Email anzuhängen.

Einige Dateitypen wie *.exe, *.vbs, etc. werden vom Programm nicht akzeptiert. Diese Dateitypen können potentiell Viren enthalten. Falls Sie solche Dateien versenden wollen, packen Sie diese mit einem Pack-Programm ein, z.B. WinZip.

Dateianhänge können aus Sicherheitsgründen nicht mit einer DEMO-PIN versendet werden.

TIP: Überprüfen Sie Ihre angehängten Dateien vor dem Versand auf Viren.

Auswahl von Adressen

Schnelle Suche (F6)

Wechseln Sie zur Adressen-Tabelle. Klicken Sie dort auf die Schaltfläche Suchen....

Es erscheint der Dialog zur Auswahl von Adressen (siehe Screenshot).

Nachdem Sie eine bestimmte Auswahl getroffen haben, klicken Sie auf "OK". In der Tabellenansicht der Adressen werden jetzt nur die ausgewählten Datensätze angezeigt.

Klicken Sie dort auf "Alle Sätze", um die Auswahl zurückzusetzen.

Die Auswahl hat Einfluß auf die Funktion "Mailing generieren".

Wählen Sie beim Generieren des Mailings die Option "Aktuelle Auswahl", um ein Mailing auf Basis der gewählten Auswahl zu generieren.

 
Adressen Auswahl

Erweiterte Suche (F7)

 

Wechseln Sie zur Adressen-Tabelle. Klicken Sie dort auf die Schaltfläche Erweitert....

Es erscheint der Dialog zur erweiterten Auswahl (siehe Screenshot).

Nachdem Sie eine bestimmte Auswahl getroffen haben, klicken Sie auf "OK". In der Tabellenansicht der Adressen werden jetzt nur die ausgewählten Datensätze angezeigt.

Klicken Sie dort auf "Alle Sätze", um die Auswahl zurückzusetzen.

Die Auswahl hat Einfluß auf die Funktion "Mailing generieren".

Wählen Sie beim Generieren des Mailings die Option "Aktuelle Auswahl", um ein Mailing auf Basis der gewählten Auswahl zu generieren.

 
Erweiterte Auswahl

Suche zurücksetzen (F8)

Drücken Sie F8, um die Suche zurückzusetzen und wieder alle Datensätze anzuzeigen.

Mailing generieren

 

Durch die Funktion "Mailing generieren" werden die Emails auf Basis der aktuellen Datenbankauswahl zusammengestellt und in den Postausgang gelegt.

  1. Verfassen Sie eine Email
  2. Selektieren Sie eine Gruppe von Datensätzen durch eine Datenbankauswahl (Auswahl oder Erweiterte Auswahl) und/oder markieren Sie mehrere Datensätze mit gedrückter Strg-Taste.
  3. Wählen Sie im Hauptmenü "Mailing->Mailing generieren"
  4. Wählen Sie im folgenden Dialog, ob das Mailing an
    • die gesamte Auswahl
    • nur die markierten Datensätze
    generiert werden soll.

    Mailing generieren

  5. Bestätigen Sie mit OK. Die einzelnen Mails werden nun zusammengestellt
  6. Es erscheint eine Vorschau der generierten Mails. Kontrollieren Sie die einzelnen Mails. Sie können hier einzelne Mails noch bearbeiten oder löschen.
  7. Durch Klick auf den entsprechenden Button werden die Mails in den Postausgang gelegt.

BCC-Mailing (Blind Carbon Copy)

Wählen Sie diese Option normalerweise nicht.

BulkMailer sendet ohne diese Option an jeden Empfänger eine separate Email. Keiner der Empfänger sieht dabei die Adressen der anderen Empfänger.

Die BCC Option ist nur für den besonderen Zweck gedacht, wenn Sie einen größeren Dateianhang an eine große Empfängergruppe senden wollen und dabei auf anderem Wege eine zu große Datenmenge an den Mailserver übertragen werden müsste.

Im BCC Modus fasst BulkMailer die Mails zu BCC Blöcken zusammen, so als wenn Sie in Ihrem Emailprogramm die Mail an sich selbst adressieren und jeweils 50 Empfänger in das BCC Feld ziehen.

Dieser Modus hat jedoch zwei wesentliche Nachteile:

  • Dadurch, dass dieselbe Mail an mehrere Empfänger geht, können keine persönliche Anrede oder andere Personalisierungen in der Mail versendet werden.
  • Eine größere Anzahl von BCC-Mails wird häufiger von traffic-basierten Spam-Filtern aussortiert.

Die Blockgröße der BCC Mails können Sie unter "Optionen->BCC" konfigurieren.

Vorschau des Mailings

Mailing Vorschau

Nach dem Generieren erscheint eine Vorschau des Mailings. Hier sollen Sie prüfen, ob alles in Ordnung ist, insbesondere ob alle Datenbankinhalte nach Ihren Wünschen eingesetzt wurden und die persönlichen Anreden wie gewünscht eingefügt wurden.

Klicken Sie auf "In den Postausgang legen", um diese Mails in den Postausgang zu legen, damit sie von dort aus versendet werden können.

Mails versenden

 

Um vorhandene Mails aus dem Postausgang zu versenden, wählen Sie "Mailing->Mailing versenden (SMTP)".

Nach Bestätigung der Lizenzbestimmungen und Validierung der PIN erscheint der Versenden Dialog.

Achten Sie darauf, daß Sie mit dem Internet verbunden sind und wählen Sie "Start !"

Daraufhin sollte der Mailversand beginnen.

Folgende Anmerkungen zum Mailversand:

  • Sie können den Versand jederzeit unterbrechen und fortsetzen.
  • Nur Mails, die fehlerfrei versendet wurden, werden aus dem Postausgang gelöscht.
  • Zu jedem Mailing wird ein Sendeprotokoll als Datenbank angelegt. Dies ermöglicht die Option, eine doppelte Zustellung derselben Email an denselben Empfänger zu verhindern.
 
Senden Dialog

 

divider

Fortgeschrittene Techniken

Datenbank Import

Die Importfunktion von BulkMailer erlaubt es, Daten aus anderen Datenquellen in eine BulkMailer Adressdatenbank zu importieren.

Wenn Sie eine "Andere Datenquelle" geöffnet haben, ist ein Import nicht möglich, da "Andere Datenquellen" nur lesend geöffnet werden. Öffnen Sie in diesem Fall erst eine BulkMailer Adressdatenbank oder erstellen Sie eine neue BulkMailer Adressdatenbank.

Wählen Sie dann Menü "Datei->Adressen importieren..."

Datenbank Import Dialog

Wählen Sie die gewünschte Datenquelle und klicken Sie auf "Öffnen..."

Es erscheinen weitere Dialoge zur Verbindung mit der Datenquelle.

Für MS-Access, MS-Excel Tabellen, MS-SQL-Server, Text/CSV-Dateien, MS Outlook Express (Windows Adressbuch) und MS Outlook erscheinen spezialisierte Dialoge.

Wählen Sie "BulkMailer Adressdatenbank", um Adressen aus einer anderen BulkMailer Adressdatenbank an Ihre aktuell geöffnete Datenbank anzuhängen.

Wählen Sie "andere Datenbank", um aus einem nicht aufgeführtem Format zu importieren. BulkMailer öffnet dann den "Datenverknüpfungseigenschaften Dialog", mit dessen Hilfe Sie sich mit allen Datenquellen verbinden können, zu denen ein OLEDB-Provider oder ein ODBC Treiber verfügbar ist.

Zu ODBC-Datenquellen ist es u.U. erforderlich, dass Sie zuvor über die Systemsteuerung und den ODBC Manager einen System-DSN erstellen, auf den Sie hier im folgenden zugreifen.

Bei Datenbankformaten erfolgt nach der Verbindung mit der Datenquelle eine Auswahl der Tabelle oder Abfrage.

Nachdem Sie erfolgreich eine Verbindung zu Importdatenquelle hergestellt haben, sehen Sie im unteren Bereich eine Vorschau auf die Daten aus der Importquelle.

Mit den zwei Pfeilen blättern Sie durch diese Daten.

Ordnen Sie zu den relevanten Feldern der Importtabelle links daneben in den Drop-Down-Listen die Zielfelder in der BulkMailer Adressdatenbank zu. Nur zugeordnete Felder werden importiert. Ordnen Sie mindestens das Feld "Email" zu.

Da das Zuordnen der einzelnen Spalten mühsam ist, können Sie die Zuordnungen mit Hilfe der entsprechenden Schaltflächen speichern und laden

Klicken Sie auf "Importieren" um den Import zu starten. Es erscheint ein weiterer Dialog mit einigen Optionen zum Import.

  • Nur gültige Adressen importieren: Adressen mit fehlerhafter Syntax oder leere Adressen werden nicht importiert.
  • Keine doppelten Emailadressen: BulkMailer prüft beim Importieren auf doppelte.
  • Geschlecht automatisch erkennen: BulkMailer besitzt eine umfangreiche Datenbank mit Vornamen und kann das Geschlecht anhand des Vornamens bestimmen.
  • Titel automatisch extrahieren: Hiebei geht es um den akademischen Titel wie Dr. oder Prof. BulkMailer versucht den Titel automatisch zu erkennen und in das gesonderte Feld Titel zu extrahieren.

Adressen exportieren

Die Adressen können in eine Textdatei mit Delimiter (Begrenzungszeichen) exportiert werden. Solche Textdateien können von den allermeisten Datenbankprogrammen gelesen und importiert werden.

Zu diesem Format gibt es eine Reihe von Optionen, die Sie beim Export aus BulkMailer wählen können. Welche Optionen Sie wählen sollten hängt davon ab, in welchem anderen Programm Sie diese Datei weiterverarbeiten wollen.

  • Wählen Sie im Hauptmenü "Datei -> Adressen exportieren..."
  • Wählen Sie das Zielverzeichnis und geben Sie einen Dateinamen an
  • Es erscheint der Dialog zu den Export-Optionen.

In der Adressen-Tabelle können Sie mit dem Icon "Feldliste" einzelne Spalten ein- und ausblenden. Wählen Sie dies in Verbindung mit der Export-Option "Nur sichtbare Spalten exportieren", um nur bestimmte Spalten zu exportieren.

 
Addressen exportieren

Gruppen verwalten

 

In der Adressdatenbank werden Adressen zu bestimmten Gruppen zugeordnet. Diese Gruppen dienen der Auswahl von Datensätzen. Jede Gruppe besitzt eine bestimmte Anredeart

Sie können die vordefinierten Gruppen um neue erweitern.

Gruppen bearbeiten

Wenn Sie eine Gruppe löschen, werden dabei auch alle abhängigen Adressen gelöscht.

Anreden verwalten

 

Hier definieren Sie, wie das automatische Feld "[Anrede]" generiert wird.

Die Anrede-Arten Höflich, Persönlich, Cool sind jeweils den Gruppen zugeordnet, siehe Gruppen verwalten.

Fügen Sie Feldinhalte wie in der Auflistung angezeigt ein.

Anreden bearbeiten

BulkMailer Profile

Arbeiten mit Profilen

BulkMailer unterstützt ab der Version 5 das Arbeiten mit verschiedenen Profilen. Wählen Sie Manü "Datei->Profile" um ein Profil zu öffnen, neue Profile anzulegen und Profile zu bearbeiten.

Sie können beliebig viele Profile anlegen.

Profile  

Jedes Profil besitzt seine eigenen Daten und Einstellungen:

  • Nachrichtentexte (Datei Mailings.mdm)
  • Adressdatenbank (Datei Addresses.bm3)
  • Ausschlußliste (Datei Exclude.mdb)
  • Postausgang (Datei outbox.mdb und Verzeichnis \Outbox\)
  • Einstellungen (unter Extras->Optionen)

Diese Daten werden unter \Eigene Dateien\BulkMailer\ in jeweils einem eigenen Verzeichnis Profile-00000x (fortlaufende Nummer) angelegt.

Adressdatenbanken und Ausschlußlisten können auch profil-übergreifend verwendet werden.

Nach Erstellung eines neuen Profils wird erstmal eine eigene leere Adressdatenbank und Ausschlußliste angelegt.

Später können Sie eine andere BulkMailer Adressdatenbank öffnen über den Menüpunkt "Datei->BulkMailer Adressdatenbank öffnen...". Ebenso eine andere Ausschlußliste über "Ausschluß->Andere Ausschlußdatenbank öffnen...". Die zuletzt geöffnete Adressdatenbank und Ausschlußliste wird dann beim nächsten Öffnen des Profils wieder geladen

Auf diesem Wege können sich also mehrere Profile dieselbe Adressdatenbank oder Ausschlußliste teilen.

TIP: Verschieben Sie gemeinsame Dateien in einen separaten Ordner. Dann haben Sie später einen besseren Überblick, welche Dateien global verwendet werden.

Beim Löschen eines Profils werden alle zugehörigen Daten gelöscht. Achten Sie darauf, dass diese Daten nicht auch von anderen Profilen verwendet werden.

Um ein Profil löschen zu können, darf das Profil nicht geöffnet sein.

Scripting

 

BulkMailer kann beim Generieren der Emails VBScript-Code innerhalb des Mailtextes ausgeführen. Sie können dadurch den Inhalt jeder einzelnen Email durch eigene Programmierung steuern.

Hierbei geht es um Scripte, die im BulkMailer im Schritt Mailing generieren ausgeführt werden können, um die Email zu personalisieren. Die ausgehende Mail enthält dann keinerlei Scripte mehr.

Durch zwei BulkMailer Script-Objekte greifen Sie dabei auf die Objekte der Email zu. Dadurch können Sie

  • Text ausgeben
  • Dateianhänge an die Email anhängen
  • die Betreffzeile modifizieren
  • Texte/Textbausteine aus Dateien laden
  • auf den aktuellen Datensatz zugreifen

Sie können dadurch beispielsweise folgende Aufgaben bewältigen:

  • Alle Empfänger der Domain xyz.de erhalten einen anderen Textinhalt
  • Alle Interessenten für das Produkt xyz erhalten eine Produktinformation als Dateianhang
  • [..]

Voraussetzungen

Sie benötigen wenigstens geringe Programmierkenntnisse in VBScript.

Script-Block Maskierung

Ein Script-Block wird durch die Zeichenfolge


<% Script-Code %>

maskiert. Eine Email kann mehrere Script-Blöcke enthalten
Innerhalb dieser Markierung kann beliebiger VBScript-Code angegeben werden.

  • In einer Nur-Text Mail fügen Sie diesen Script-Block direkt in den Nachrichtentext ein
  • In einer HTML-Mail fügen Sie den Script-Block in den HTML-Quelltext ein
Beispiele:
Zahlen von 1 bis 100

<%
For i = 1 To 100
   Email.Textout i & vbCrLf
Next
%>
Aktuelles Datum

<% Email.TextOut FormatDateTime(Now, 1) %>

Das Email-Objekt

Innerhalb des Script-Codes steht Ihnen das Email-Objekt mit folgenden Methoden und Eigenschaften zur Verfügung:

Ausgabe der Zeichenkette

Betreff lesen/ändern

Datei anhängen

Den Inhalt der Textdatei an dieser Position einfügen

Diese Email nicht weiter generieren, nicht zum Postausgang zufügen

Das Record-Objekt

Rückgabewert: Inhalt des aktuellen Wertes aus dieser Spalte als Text.

Rückgabewert: Inhalt des aktuellen Wertes aus dieser Spalte als Variant.
(Kann NULL-Werte, Zahlenwerte, etc. enthalten)

Die BulkMailer Adressdatenbank verwendet intern andere Spaltennamen, als in der Anwendung angezeigt. Eine Auflistung der Spaltennamen finden Sie im Anhang.

Beispiele


<%
If InStr(1, Record("Email"), "@xyz", vbTextCompare) <> 0 Then
	Email.LoadTextfile "d:\mails\abc.txt"
Else %>
	Standard Mailtext
<% End If %>

<%
If Record("InteresseXYZ") = True Then
	Email.AttachFile "d:\produktinformation\produktxyz.pdf"
End If
%>;

*(Ihre Datenbank enthält eine Spalte "InteresseXYZ" vom Typ Bool)


<%
' --- Geburtstag berechnen
If IsDate(Record.Value("Birthday")) Then
	Const CDays = 7 ' --- kann angepasst werden
	Dim dtBirthDay
	Dim lDiff

	dtBirthDay = DateSerial(Year(Now), Month(Record.Value("Birthday")), Day(Record.Value("Birthday")))

	' --- Überlauf berücksichtigen
	If 365 - DateDiff("d", Now, dtBirthDay) <= CDays Then
		dtBirthDay = DateAdd("yyyy", -1, dtBirthDay)
	End If
	lDiff = DateDiff("d", Now, dtBirthDay)

	If lDiff <= 0 And lDiff >= -CDays Then  ' hatte in den letzten 7 Tagen Geburtstag
		' --- Textbaustein einfügen
		Email.LoadTextfile "d:\Geburtstag.txt"     ' --- muss angepasst werden
	End If
End If
%>;

 

VBScript Sprachreferenz

Eine Sprachreferenz zu VBScript finden Sie in der
MSDN Library

Hinweise zum Markenschutz

VBScript ist eine Technologie der Firma Microsoft. Dank der hervorragenden Schittstellen zu dieser Technologie ist eine Integration in diese Anwendung möglich gewesen.

Spaltennamen der BulkMailer Adressdatenbank

 
Deutsch Englisch BulkMailer Adressdatenbank
ID ID ID
Titel Title Title
Vorname Firstname FirstName
2. Vorname Second Name SecondName
Nachname Lastname LastName
Spitzname Nickname NickName
Anzeige-Name Display-Name DisplayName
Email Email EMail
Gruppe Group Gruppe
Privat:Land Private:Country Private_Country
Privat:Staat Private:State Private_State
Privat:PLZ Private:ZIP Private_PostalCode
Privat:Ort Private:City Private_City
Privat:Strasse Private:Street Private_Street
Privat:Telefon Private:Phone Private_Phone
Privat:Fax Private:Fax Private_Fax
Privat:Mobil Private:Mobile Private_Mobile
Privat:Homepage Private:Homepage Private_Homepage
Firma Company Business_Company
Firma:Titel Biz.:Title Business_Title
Firma:Abteilung Biz.:Department Business_Department
Firma:Bro Biz.:Office Business_Office
Firma:Land Biz.:Country Business_Country
Firma:Staat Biz.:State Business_State
Firma:PLZ Biz.:ZIP Business_PostalCode
Firma:Ort Biz.:City Business_City
Firma:Strasse Biz.:Street Business_Street
Firma:Telefon Biz.:Phone Business_Phone
Firma:Fax Biz.:Fax Business_Fax
Firma:Pager Biz.:Pager Business_Pager
Firma:IP-Phone Biz.:IP-Phone Business_IP_Phone
Firma:Homepage Biz.:Homepage Business_Homepage
Kommentar Comment Comment
Geschlecht Gender Gender
Geburtstag Birthday Birthday
Hochzeitstag Anniversary Wedding_Day
Standard Adresse Standard Address Default_Address_Index
Präferenz Preference Send_Internet_Encoding
Benutzerdefiniert 1 User Defined 1 User1
Benutzerdefiniert 2 User Defined 2 User2
Benutzerdefiniert 3 User Defined 3 User3
Benutzerdefiniert 4 User Defined 4 User4
Benutzerdefiniert 5 User Defined 5 User5
Erstellungsdatum Date Created Record_Created
Letzte Änderung Date Changed Record_Changed

BulkMailer EULA

Lizenzbestimmungen

§ 1 Gegenstand

Gegenstand dieser Lizenzbestimmungen ist das Computerprogramm BulkMailer Professional, die Online-Anwenderdokumentation sowie sonstiges zugehöriges schriftliches Material, nachfolgend zusammenfassend als Software bezeichnet.

§ 2 Zusicherungen

(1) Diese Software wird Ihnen zur Verfügung gestellt "so wie sie ist".

(2) Kroll Software-Entwicklung macht keinerlei Zusicherungen bezüglich Funktionstüchtigkeit, Fehlerfreiheit oder Verwendbarkeit zu einem bestimmten Zweck.

§ 3 Evaluierung

(1) Sie dürfen das Programm 30 Tage lang kostenlos und unverbindlich testen, um zu überprüfen, ob es Ihre Arbeit unterstützt.

(2) Danach müssen Sie eine Nutzungslizenz erwerben, wenn Sie das Programm weiterhin nutzen wollen.

§ 4 Nutzungslizenz

(1) Die Nutzungslizenz berechtigt zum Einsatz der Software an einem Arbeitsplatz. Eine zeitgleiche Nutzung auf mehr als einer Hardware erfordert eine Mehrfachlizenz.

(2) Die Nutzungslizenz ist an eine oder mehrere bestimmte Absender-EMail-Adresse(n) gebunden. Diese EMail-Adressen können nachträglich kostenlos geändert werden lassen. Eine solche Umschaltung dauert bis zu maximal einer Woche. Weitere EMail-Absenderadressen können gegen Gebühr gesondert bestellt werden.

§ 5 Auslieferung

(1) Diese Software wird ausschließlich online zum Download angeboten. Auch bei Lizensierung werden keine Datenträger oder gedruckten Handbücher dem Kunden überlassen.

§ 6 PIN-Validierung

(1) Vor jedem Mailversand prüft das Programm die Gültigkeit einer persönlichen Identifikations Nummer (PIN). Diese ist an eine bestimmte Absenderadresse gebunden. Durch diesen Mechanismus soll ein Mißbrauch des Programms vermieden werden.

(2) Kroll Software-Entwicklung versichert, daß bei der PIN-Überprüfung neben Ihrer EMail-Adresse, PIN und Versionsnummer keine weiteren Daten übertragen werden. Ihre EMail-Adresse wird nicht an Dritte weitergegeben.

(3) Da die Überprüfung der PIN online geschieht, kann eine 100-prozentige Verfügbarkeit nicht zugesichert werden.

§ 7 Mißbrauch

(1) Das unaufgeforderte Versenden von Werbe-Emails und sogenannten SPAM-Mails ist in vielen Ländern verboten. BulkMailer wurde nicht zu diesem Zweck entwickelt.

(2) Die Verwendung der Software für Spamming wird als Mißbrauch aufgefaßt und führt zum Verlust der Nutzungserlaubnis.

(3) Kroll Software-Entwicklung behält sich vor, Benutzer, die diese Software für Spamming mißbrauchen, von der Benutzung auszuschließen, insbesondere, wenn Kroll Software-Entwicklung von dritter Seite verklagt oder abgemahnt wird. Solche Benutzer hätten keine weiteren Ansprüche gegen Kroll Software-Entwicklung, beispielsweise Rückerstattung der Lizenzgebühr o.ä.

§ 8 Dekompilierung und Programmänderungen

(1) Die Rückübersetzung des überlassenen Programmcodes in andere Codeformen (Dekompilierung) sowie sonstige Arten der Rückerschließung der verschiedenen Herstellungsstufen der Software (Reverse-Engineering) einschließlich einer Programmänderung sind unzulässig.

(2) Die Entfernung eines Kopierschutzes oder ähnlicher Schutzroutinen ist unzulässig.

(3) Urhebervermerke, Seriennummern sowie sonstige der Programmidentifikation dienende Merkmale dürfen auf keinen Fall entfernt oder verändert werden.

§ 9 Haftung

(1) Bei Schäden und Folgeschäden, die durch den Einsatz dieser Software entstehen, haftet Kroll Software-Entwicklung maximal bis zum 1-fachen Kaufpreis.

(2) Die Haftung für Datenverlust wird auf den typischen Wiederherstellungsaufwand beschränkt, der bei regelmäßiger und gefahrentsprechender Anfertigung von Sicherungskopien eingetreten wäre.

§ 10 Schriftform

(1) Änderungen oder Ergänzungen dieser Vertragsbedingungen, besondere, über die übliche Vertragsabwicklung hinausgehende Vereinbarungen sowie sonstige besondere Zusicherungen und Abmachungen dürfen von den Mitarbeitern des Lieferanten nicht erklärt werden. Sie sind nur nach einer schriftlichen Bestätigung durch den Lieferanten verbindlich.

§ 11 Gerichtsstand

(1) Gerichtsstand ist in jedem Fall Altdorf, Switzerland

 

Kroll Software-Entwicklung,   Altdorf, den 20.06.2015

 

Feedback Modul

 

Mit dem Feedback Modul können Sie die Behandlung von Antwort-Mails automatisieren. Es unterstützt Bounce-Management und verwaltet die Anmeldungen.

BulkMailer Datensicherung und Übernahme auf einen anderen Rechner

Wie wichtig eine gute Datensicherung ist, erkennt man oft erst wenn es zu spät ist. Festplatten fallen wie Glühbirnen irgendwann aus, Rechner werden gelegentlich gestohlen oder die empfindliche Elektronik bei Blitzschlag zerstört.

Datensicherung der BulkMailer Programmdaten

BulkMailer speichert alle Daten in einem separaten Datenverzeichnis.

In der Version 5 ist dies
\Eigene Dateien\BulkMailer\

Ab der Version 6 wählen Sie Extras->Datenverzeichnis festlegen, um dieses Verzeichnis zu ermitteln. Im ersten Eingabefeld steht der komplette Pfad. Schließen Sie dieses Fenster wieder mit "Abbrechen".

Per Voreinstellung ist dies
\AppData\Roaming\Kroll-Software\BulkMailer\
Oder suchen Sie mit der Windows Suchfunktion nach der Datei BulkMailer.cfg

Sichern Sie dieses komplette Verzeichnis mit allen Dateien und Unterordnern (z.B. auf einen USB Stick, was das derzeit sicherste und langlebigste Medium ist).

Datenübernahme auf einen anderen Rechner

Installieren Sie BulkMailer und starten Sie das Programm erstmalig. Im Menü Extras-Datenverzeichnis festlegen können Sie nun das Datenverzeichnis sehen, welches BulkMailer gewählt hat. Der volle Pfad steht im ersten Eingabefeld. Dann schließen Sie BulkMailer und kopieren Ihre Sicherungsdateien an diesen Ort (in das Datenverzeichnis). Sie können dabei die leeren Datenbanken überschreiben, die BulkMailer bereits angelegt hatte.

Falls BulkMailer eine Datenbank nicht findet, legt er beim Starten einfach eine neue leere an. Solche leeren Datenbanken können Sie einfach mit Ihren Daten überschreiben.

Der Pfad zum Datenverzeichnis ist vom angemeldeten Windows-Benutzer abhängig. Daher sind weitere Anpassungen erforderlich, falls sich der Windows-Benutzername geändert hat:

WICHTIG

Falls der Windows-Benutzer anders heisst, öffnen Sie die Datei "BulkMailer.cfg" im Datenverzeichnis mit einem Plain-Text Editor* und korrigieren Sie alle Datei-Pfade darin an die neuen gültigen Pfade.

*) nutzen Sie dazu Notepad oder Windows Editor, jedoch nicht Wordpad oder MS-Word.

Übernahme einzelner Dateien

Alternativ können Sie auch nur die einzelnen Datenbanken zurückschreiben, das sind im Wesentlichen in jedem BulkMailer-Profile Ordner:

  • *.bm3: die BulkMailer Adressdatenbanken
  • Exclude.mdb: Die Ausschlussliste

(Diese beiden können Sie auch aus dem Programm heraus über die entsprechenden Menüpunkte öffnen.)

  • Mailings.mdm: Die Nachrichtentexte

BulkMailer Adress-Datenbanken

Durchsuchen Sie Ihre Festplatte nach *.bm3 Dateien.
Öffnen Sie die BulkMailer Adressdatenbanken durch Menü Datei->BulkMailer Adressdatenbank öffnen..

Ausschlussliste

Durchsuchen Sie Ihre Festplatte nach "Exclude.mdb" Dateien.
Öffnen Sie die Ausschlussliste durch Menü Ausschluss->Andere Ausschlussdatenbank..

Datenzugriff ohne BulkMailer

Alle verwendeten Datenbanken sind MS-Access Datenbank Dateien, die Sie auch mit MS-Access bearbeiten können.

Gut zu wissen: Ihre Daten gehen nie verloren. Selbst ohne die BulkMailer Anwendung können Sie stets Ihre Daten mit MS-Access öffnen, oder anderen Anwendungen, die MS-Access Dateien öffnen können.

Wenn Sie eine *.bm3 Datei mit MS-Access öffnen wollen, geben Sie dort in der Dateimaske im Öffnen-Dialog *.bm3 ein. Es sollten dann alle bm3-Dateien aufgelistet werden und Sie können eine davon öffnen. Dasselbe gilt für Mailings.mdm

BulkMailer: Loggen auf Protokoll-Ebene

Wenn Sie Verbindungsprobleme analysieren oder den Verlauf einzelner Mails nachverfolgen wollen, indem Sie Sendeprotokolle mit Mailserver-Logs vergleichen, kann manchmal ein vollständiges Log aller Daten des SMTP-Dialogs hilfreich sein.

Für solche Zwecke bietet BulkMailer eine Trace-Log Funktion.

Vielleicht finden Sie dies auch interessant, wenn Sie sich für die technischen Details interessieren, wie BulkMailer die Kodierungen einer typischen MIME Nachricht umsetzt (multipart, Kopfzeilen-Kodierung, quoted-printable, Zeilenlängen und -Umbrüche in UTF-8 kodierten Emails, challenge-response bei der Anmeldung, etc.).

BulkMailer besitzt seine ganz eigene SMTP und MIME Implementierung, entwickelt von Kroll-Software und unbeeinflusst von anderen Bibliotheken. Es ist eine von Grund auf eigenständige Entwicklung die strikt den relevanten RFCs folgt. Dies mag ein Grund für den Erfolg dieser Software sein: BulkMailer erfüllt die RFC Standards besser als die meisten anderen Mailer.

1. Aktivierung des Trace-Logs

Im Senden-Fenster, gerade bevor Sie auf [Start] klicken, um den Versand zu beginnen, drücken Sie die Tasten <Strg-t>. Ein Meldungsfenster sollte darauf um Bestätigung bitten.

2. Senden Sie einige Emails

Klicken Sie auf [ Start ] um die Emails zu versenden.

3. Analyse des Trace-Logs

Sie finden die Datei "trace.log" im BulkMailer Datenverzeichnis.

Um das BulkMailer Datenverzeichnis zu ermitteln, wählen Sie Menü Extras->Datenverzeichnis festlegen. Den vollständigen Pfad sehen Sie im ersten Eingabefeld. Schließen Sie dieses Fenster wieder ohne Änderung durch "Abbrechen".

Öffnen Sie die trace.log Datei mit einem Text-Editor.

Teilen Sie die Trace-Log Datei mit dem Administrator des Mailservers, damit er dadurch helfen kann, Probleme genau zu analysieren. Geben Sie die Datei jedoch nicht an andere Dritte weiter, denn sie könnte geheime Passwörter enthalten.

Grenzen

Log-Dateien können schnell sehr groß werden und überschreiten die 2,4 gig Grenze für die maximale Dateigröße mit Leichtigkeit.

Diese Trace-Funktion fügt stets an die bestehende Datei an. Fehler werden nicht behandelt. Die Funktion wurde entworfen, um bestimmte Probleme zu ermitteln und dient nicht dem generellen täglichen Gebrauch. Um eine neue Log-Datei zu beginnen, löschen Sie einfach die trace.log Datei, bevor Sie ein neues Trace starten.

BulkMailer im Netzwerkbetrieb

BulkMailer unterstützt den Betrieb im lokalen Windows-Netzwerk durch mehrere Benutzer.

Das Programm verwaltet dabei konkurrierende Zugriffe auf die BulkMailer Adressdatenbanken und Ausschlusslisten, d.h. es kann gemeinsam und gleichzeitig an diesen Daten gearbeitet werden.

Dabei besitzt jeder Benutzer seine eigenen Nachrichtentexte und Postausgang. Das gemeinsame Bearbeiten von Texten ist nicht vorgesehen, ebenso nicht der gemeinsame Versand aus demselben Postausgang durch mehrere Clients. Daher sollten diese Daten bei jedem Nutzer lokal verwaltet werden.

Installation

  1. Installieren Sie dazu BulkMailer auf jedem Clientrechner.
  2. Kopieren Sie die gemeinsamen Adressdatenbanken (*.bm3) und Ausschlusslisten (Exclude.mdb) auf einen Windows Server oder einen anderen zentralen Windows Rechner in Ihrem lokalen Netzwerk.
  3. Öffnen Sie von jedem Client aus die zentrale Adressdatenbank durch Menü
    Datei->BulkMailer Adressdatenbank öffnen..
  4. Für die zentrale Ausschlussdatenbank wählen Sie Menü
    Ausschluss->Andere Ausschlussdatenbank öffnen..

Die gleichzeitige Nutzung durch verschiedene Anwender von unterschiedlichen Rechnern erfordert eine Mehrfachlizenz.